Unscheduled Discord Community Server Maintenance
Incident Report for Get The Freight Out
Resolved
This incident has been resolved.
Posted Oct 03, 2019 - 15:06 PDT
Identified
We are currently doing some minor tweaks to our community Discord server. For those who use it you will experience issues viewing specific channels. Please don't be alarmed as that is normal and we are working to resolve those issues and make some regular updates to role permissions.
Posted Oct 03, 2019 - 14:34 PDT